Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
403 Forbidden due to Nginx
07-26-2011, 10:58 AM (This post was last modified: 08-01-2011 11:34 AM by kidsinhalf.)
Post: #1
403 Forbidden due to Nginx
First of all, thanks for having liberated affiliatesforall.
Actually, it is the first time I meet an installation problem with this module for a magento solution.

The problem is simply that the folder /afa/ gives a 403 Forbidden error page.
If I try /afa/public/ the I can see the login page but it is not designed and the forms don't work.

Naturally, I tried to modify the htaccess in the /afa/ folder.

i have identified that if a folder is empty, it always shows the 403. So I suspect the root htaccess to rule the /afa/ htaccess.

This htaccess is the original embedded with magento pack.

So I think it is not a problem in affiliatesforall scripts. But maybe somebody has solved the problem.
Find all posts by this user
Quote this message in a reply
07-28-2011, 05:38 PM
Post: #2
RE: 403 Forbidden
Ok, I have not yet solved the problem but I discovered why it doesn't work.
In fact, the servor is not Apache but Ningx. So the .htaccess files don't work at all...

Unfortunately, I have no idea how ningx is customable...

Any idea
Find all posts by this user
Quote this message in a reply
07-07-2012, 03:43 PM
Post: #3
RE: 403 Forbidden due to Nginx
Dear community,

i have too this problem. The magento community recommend the nginx webserver for magento and i use it.
Please update the installation guide, when the nginx user too use this affiliate software.

this is my error message:

"Fatal error: Affiliates for All requires the following PHP settings: magic_quotes_gpc off, magic_quotes_runtime off, magic_quotes_sybase off in /affiliate/lib/bootstrap.php on line 88"

anyone have an idea? how to solve this? i like use afa.

thakn you
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)